
What is IconFun Express?

IconFun Express is designed to locate files that contain icons on floppies, hard-disks and CD-ROM’s. It searches entire disks or
only selected folders and it will scan all files or only the file types specified by the user. It converts icons to bitmaps and bitmaps 
to icons, and creates detailed scan reports. And more..



Version history

Thanks to all users who have reported bugs and commented on IconFun Express.

Version 2.30
IconFun Express now allows you to select not to report scan results if no icons are found.
IconFun Express now allows you to select if you want to confirm the name of each icon or bitmap when saving or the 

program should use a default naming scheme.
Double clicking an icon will start up the associated program with the icon as parameter - ready to be edited. The user 

decide if it should be in the icon- or the ordinary image editor.
When you decide to scan all files for icons, you now have the possibility to choose to exclude bitmaps - .BMP-files.
The parameter /NOSPLASH is no longer available.
New popup-menu.
Minor changes.

Version 2.23
IconFun Express now allows you to cancel saving all selected icons by clicking cancel only one time in the save dialog 

box.
Scan report files now tells whether subfolders were included in a scan.
Now with un-install feature.
Root folder in browse directory dialog box changed from desktop to drives.
IconFun Express now allows you to select that all files in the selected folder should be scanned for icons.
Minor changes.

Version 2.22
Date seperator chars changed from “/” to “-“. Since slashes are illegal characters in file names, it caused an error each 

time IconFun Express saved a report file (The program is translated from danish where slashes is not used as date seperators).
The home of the english version of IconFun Express is now at http://www.geocities.com/SiliconValley/Way/5646. Future 

versions may be downloaded from there.

Version 2.2 and 2.21
Initial releases. First versions in english.



System requirements

In order to run IconFun Express, your system must meet these specifications:

An IBM PC or compatible that meets the minimum hardware requirements for your version of Microsoft Windows.
Windows95 installed on your computer.
Note: IconFun Express has not yet been tested on Windows NT!
A mouse or other pointing device.



File list

Included in the IconFun Express archive file are the following files:

File

file_id.diz

ifx.exe

ifx.hlp

ifx.cnt

Description

Description.

Main program file.

Program help file.

Program help file index.

Installation

1. Create a new folder: IFX.

2. Copy all files to the new folder.

3. Create a shortcut to ifx.exe from your desktop or start-menu.



Uninstallation

1. Delete the key: IconFun Express from the Registry.

2. Delete the program folder manually.



How to configure a scan

1. Enter a path in the Scan in field, or click Browse to select desired location.

2. Select Include subfolders to search for icons in all subfolders within the main folder just specified.

3. Select All Files to search for icons in all files, or These file types only to only search for icons in the specified file types.

Tip!

Click here to set scan report preferences.



How to start scanning

1. Specify the desired path and file options on the Where & What tab.

2. Click Scan Now.

Tip!
To terminate scanning, click Stop.



How to save icons

1. Select the desired icon(s).

2. Choose Save As from the File menu or the popup menu.

3. Depending on how you have setup the save procedure, you will be asked:

a. Once to specify file type and save folder for all the selected icons, or

b. To confirm the name of each selected icon.

Tip!
To setup save procedure, choose Preferences in the View menu, and select the Save tab.



How to copy icons

1. Select the desired icon.

2. Choose Copy As from the Edit menu or the popup menu.

3. Choose type.



How to open icons

a. Double click the desired icon with left mouse button, or

b. Right click the icon and choose Open from the popup menu.

Tip!
To setup which program starts up, choose Preferences in the View menu, and select the Misc tab.



How to report scan results

1. Choose Preferences from the View menu.

2. Select the Reports tab.

3. Select Report scan results.

4. Select View log file after scan to instruct IconFun Express to load the log file automatically after scanning.

5. Select Do not report if no icons are found if IconFun Express should not create scan reports, when no icons are found.

6. Enter a path in the Always log to this folder field or click Browse (…) to select desired location.



How to view log files

Log files can be loaded automatically or manually:

1. Choose View Scan Log from the View menu.

2. Select desired log file.



How to set Save preferences

1. Choose Preferences from the View menu.

2. Select the Save tab.

3. Select Prompt for name if you want to confirm the name of each icon when saving.

4. Select Add index number to name if you want also to name icons with their index number when saving. 

5. Select Use default naming scheme if you do not want to confirm.

6. Enter a path in the Always save icons in this folder field or click Browse (…) to select desired location.



How to set Report preferences

1. Choose Preferences from the View menu.

2. Select the Reports tab.

3. Select Report scan results.

4. Select View log file after scan to instruct IconFun Express to load the log file automatically after scanning.

5. Select Do not report if no icons are found if IconFun Express should not create scan reports, when no icons are found.

6. Enter a path in the Always log to this folder field or click Browse (…) to select desired location.



How to set Misc preferences

1. Choose Preferences from the View menu.

2. Select the Misc tab.

3. Select Confirm exit if want to confirm exit.

4. Select Show hints in titlebar to instruct IconFun Express to show hints in the titlebar.

5. Select Open as icon if you want IconFun Express to start up your default icon editor with the selected icon as parameter 
when you double click the icon.

6. Select Open as bitmap if you want IconFun Express to start up your default image editor with the selected icon as parameter
when you double click the icon.



How to contact the author

Points of Contact:

E-mail:  tsj@post4.tele.dk.
Postal Mail: Thomas Jensen

Ormslevvej 70 B, 1., 1
8260 Viby J

Denmark.
IconFun Web: http://www.geocities.com/SiliconValley/Way/5646.
IFX_UK.zip (USA): http://www.geocities.com/SiliconValley/Way/5646/IFX_UK.zip
IFX_UK.zip (Denmark): http://home4.inet.tele.dk/tsj/IFX_UK.zip



How to get program updates

1. Choose World Wide Web and Update IconFun Express from the Help menu.

This starts up your default World Wide Web browser and connects to IconFun Web and downloads the latest version of IconFun
Express if available.

If it does not work, try entering the address manually. See downloading addresses in the How to contact the author-section.



Command line options

Option

/AUTOSCAN

Description

Starts scanning immediately after launch, 
using the scan configuration used last time.

Copyright/License/User Agreement/Distribution

IconFun Express Version 2.30
Copyright © 1996-97 Thomas Jensen
All Rights Reserved.

License:

By using IconFun Express, you accept the following Unregistered and Registered User Agreement. This agreement is a binding 
legal agreement between the author and the purchasers, users or evaluators of IconFun Express. IF YOU DO NOT INTEND TO
HONOR THIS AGREEMENT, TERMINATE THE SOFTWARE INSTALLATION NOW.

Unregistered and Registered User Agreement:

You may evaluate the Shareware (unregistered) program for a maximum of 21 calendar days, after which you must register with
the author or remove the software from your computer.

You may allow other users to evaluate copies of the unregistered program. All evaluation users are subject to the terms of this 
agreement.

The evaluator/user/buyer/owner is not allowed to attempt to reverse engineer, disassemble or decompile IconFun Express.

The author is not responsible for any damages whatsoever, including loss of information, interruption of business, personal 
injury and/or any damage or consequential damage without limitation, incurred before, during or after the use of IconFun 
Express.

Each registered copy of IconFun Express may be used in only one single location/on one computer by one user. Use of the 
program means that you have loaded the program and run it or have installed the program onto a computer. If you install the 
program onto a multi-user platform or network, each and every individual user of the program must be registered separately/be 
part of a multi user registration.

The sale of and or distribution of registered copies of IconFun Express is strictly forbidden. It is a violation of this agreement to 
loan, rent, lease, borrow, or transfer the use of registered copies of IconFun Express.

Distribution:

IconFun Express may be freely distributed, provided that:

1. Such distribution includes only the original archive supplied by the author. You may not alter, delete or add any files in the 
distribution archive.

2. The distribution does not include registration name and key.

3. No money is charged to the person receiving the program, beyond reasonable cost of packaging and other overhead.



What is registration?

IconFun Express is "Shareware". This means that the author has made the program available to you for free evaluation. You 
are entitled to evaluate the program for a period of 21 days without obligation to pay. If after the 21 day evaluation period you 
decide to keep the software, you must register with the author.

Unregistered copies of IconFun Express show a registration reminder screen on start up, and will scan EXE files only.



What are the registration benefits?

Registration entitles you free support to the program (e-mail) and free updates to all future versions. Registration removes the 
registration reminder screen, and fully enable the feature to specifying what file types IconFun Express should scan for icons.

Finally, by registering, you provide the author with the resources and incentive to support the program with updates and to 
develop additional quality shareware products in the future.



How can I register?

To register, send payment and registration form to the author:

Thomas Jensen
Ormslevvej 70 B 1 1
8260 Viby J
Denmark.

You can pay by check or cash. Please make your check payable to the author.

The author has been completely successful with receiving cash sent via the postal service. However, if you want a higher 
degree of assurance when sending cash, use registered or certified mail.

Once the author receives your registration he will send your registration key by e-mail (if he has your e-mail address) or by 
postal mail. The goal is to send your registration key within 24 hours of receiving payment.

To see what you get when registering, see Registration Benefits.

Any questions about the status of the shipment of your registration, support, multi user registration, etc. must be directed to the 
author: Thomas Jensen, Ormslevvej 70B 1 1, 8260 Viby J, Denmark, or e-mail to tsj@post4.tele.dk.



Pricing

Single user registration:
Unit price 20.00 US$

Multi user registration:
10 Users 150.00 US$

25 Users 300.00 US$

50 Users 500.00 US$



Registration form

To print this form, click Print.
To register send the completed registration form with payment to the author: Thomas Jensen, Ormslevvej 70B 1 1, 8260 Viby J. 
Denmark.

Check one registration type and one method of payment!

IconFun Express Single User Registration:     20.00 US$ [            ]

- or

IconFun Express Multi User Registration:

10 Users 150.00 US$ [            ]

25 Users 300.00 US$ [            ]

50 Users 500.00 US$ [            ]

Method of payment:

Cash [            ]

Check [            ]

Name: Date:

Company:

Address:

City, State, Zip:

Country:

Fax:

Electronic Mail address:

Homepage:

How did you hear about IconFun Express?:

Comments:



Displays where IconFun Express will begin scanning files for icons. To specify a different location, enter the path or click 
Browse.



Click here to specify where you want IconFun Express to begin its search for icons.



Selecting this option instructs IconFun Express to search for icons in all subfolders within the main folder specified in the Scan 
In field.



Click here to specify what file types you want IconFun Express to scan for icons.



Initiates scanning for icons.



Terminates scanning.



Resets all scanning options on the Where & What tab to defaults and clears all icons from the list.



Displays where IconFun Express will save icons. To specify a different location, enter the path or click browse (…).



Selecting this option instructs IconFun Express to log scanning activity.



Selecting this option instructs IconFun Express to load log files immediately after scanning.



Displays where IconFun Express will save log files. To specify a different location, enter the path or click browse (…).



Selecting this option instructs IconFun Express to ask for confirmation when exiting.



Selecting this option instructs IconFun Express to show hints in the titlebar.



Enter your registration name exactly as it appeared on the registration instructions you recieved when you became a registered 
user.



Enter your registration key exactly as it appeared on the registration instructions you recieved when you became a registered 
user.



Click here to see how to register.



Displays file types/extensions that IconFun Express will scan for icons.



Click here to add a file extension to the list.



Click here to delete a file extension from the list.



Click here to use recommended file extensions.



Enter the extension to add.



Selecting this option instructs IconFun Express to search for icons inside every file it finds.



Selecting this option instructs IconFun Express to only search for icons inside the specified file types.



Selecting this option instructs IconFun Express not to create scan reports if no icons are found.



Selecting this option instructs IconFun Express to prompt for name when saving.



Selecting this option instructs IconFun Express to add index number to the file name.



Selecting this option instructs IconFun Express to use default naming scheme when saving.



Selecting this option instructs IconFun Express to open the double clicked icon in your default icon editor.



Selecting this option instructs IconFun Express to open the double clicked icon in your default image editor.



Selecting this option instructs IconFun Express to exclude .BMP-files when scanning all files.



Use this field to specify in what type the selected icons should be saved.



Displays where icons will be saved. To specify a different location, enter the path or click Browse.



Click here to specify where you want the selected icons to be saved.






